RESOLVED: Major Issue affecting some sites and multiple services
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 19:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2022 - 19:22 UTC
Investigating
We are currently investigating a major issue in one of our data centers and working to restore service
Posted Apr 19, 2022 - 19:17 UTC
This incident affected: Site Dashboard (My Sites) and Site Loading (Site Loading).