Get Started

RESOLVED: We're investigating a potential loading issue with live sites

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 10 months ago. May 07, 2024 - 15:30 UTC

Investigating

We are currently looking into and working to resolve this issue
Posted 10 months ago. May 07, 2024 - 12:46 UTC
This incident affected: Site Loading (Site Loading).