RESOLVED: We're investigating a potential issue with creating new Wix Sites
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 13:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2023 - 13:49 UTC
Investigating
Our engineers are currently investigating an issue affecting creating a new sites. Check back here for updates.
Posted Jan 18, 2023 - 11:36 UTC
This incident affected: Site Editing (Wix Editor, ADI Editor, Editor X).