RESOLVED: Wix Hotels Dashboard Does Not Load
Incident Report for Wix
Resolved
This issue is now resolved. We thank you for your patience and understanding as we worked to resolve this issue.
Posted May 20, 2022 - 00:22 UTC
Investigating
We are currently investigating an issue that prevents the hotels dashboard from loading.
Posted May 19, 2022 - 23:02 UTC
This incident affected: Hotels (Management and Settings).