RESOLVED: Media Manager -Unable to Upload Media
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 15:15 UTC
Investigating
Some users may experience reduced performance when trying to upload media in the Editor
Posted Nov 17, 2022 - 14:59 UTC
This incident affected: Media (Upload).