RESOLVED: Issue affecting multiple Wix Services
Incident Report for Wix
Resolved
This incident is now resolved. Thank you for your patience while we worked to resolve this issue.
Posted Nov 14, 2023 - 17:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2023 - 17:08 UTC
Identified
The issue is identified and a fix is being worked on. Thank you for your patience while we work to resolve this issue.
Posted Nov 14, 2023 - 16:31 UTC
Investigating
We're investigating a potential issue affecting multiple Wix Services
Posted Nov 14, 2023 - 16:18 UTC
This incident affected: Site Editing (Wix Editor, Editor X, Wix Studio) and Site Loading (Site Loading).