Wix system status

Real-time health for Wix products and services

Track current availability, recent incidents, and service updates across the Wix platform.

Report a problem with Wix

Need help right away? Visit support.wix.com. Some issues affecting a small number of users may not appear here immediately.

RESOLVED: Unable to Publish Wix Blog

Incident Report for Wix

Resolved

The incident has been resolved.
Posted Apr 10, 2024 - 14:42 UTC

Investigating

We are currently investigating this issue.
Posted Apr 10, 2024 - 14:36 UTC
This incident affected: Blog (Blog Management).