We're investigating a potential issue with the Wix Editor
Incident Report for Wix Status Page
Resolved
This issue is now resolved. We thank you for your patience and understanding as we worked to resolve this issue.
Posted Mar 12, 2021 - 20:45 UTC
Investigating
Our engineers are currently investigating an issue affecting opening and saving the Wix Editor.
Check back here for updates.
Posted Mar 12, 2021 - 20:37 UTC
This incident affected: Site Editing (Wix Editor, ADI Editor, Editor X).