RESOLVED: Issues loading Live Sites and Wix Editor when using TalkTalk ISP

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 18 days ago. Mar 18, 2025 - 16:24 UTC

Monitoring

We're seeing a decreased number of complaints that some users in the UK are experiencing issues when accessing Wix Editor or live sites while using TalkTalk ISP due to a technical issue on TalkTalk's side.

In case you still experience these issues, please contact TalkTalk ISP directly for additional assistance with the issue.
Posted 18 days ago. Mar 18, 2025 - 15:57 UTC

Identified

We are aware that some users in the UK are experiencing issues when accessing Wix Editor or live sites while using TalkTalk ISP due to a technical issue on TalkTalk's side.

Please contact TalkTalk ISP directly for additional assistance with the issue.
Posted 18 days ago. Mar 18, 2025 - 12:41 UTC

Investigating

Please contact TalkTalk to report this issue directly to the ISP.
As a troubleshooting step, you can turn off the HomeSafe setting that may be affecting the access to the site.
Posted 18 days ago. Mar 18, 2025 - 10:29 UTC
This incident affected: Site Editing (Sign-In, Wix Editor), Customer Care (Help Center, Chatbot), and Site Loading (Site Loading).