Minor Issue with Wix Payments
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Nov 29, 2021 - 16:56 UTC
Monitoring
After investigation, no user impact was found.
Posted Nov 29, 2021 - 16:56 UTC
Investigating
Some website visitors may experience issues when trying to checkout on sites using Wix Payments.
Due to some problems on the Payment platform provider side.
We are in contact with the provider and we will update as the issue is fixed.
Posted Nov 29, 2021 - 16:21 UTC
This incident affected: Payments (Wix Payments).