RESOLVED: Live Sites Not Loading For Some of Sky Broadband Users In UK

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 15:41 UTC

Monitoring

We stopped receiving complaints regarding this matter. In case you are still experiencing the issue, please reach out to Sky's support team directly for assistance.
Posted Sep 15, 2025 - 15:25 UTC

Update

We are continuing to investigate on our side. In the meantime, please make sure to contact Sky's support team directly for assistance.
Posted Sep 15, 2025 - 12:25 UTC

Identified

We've received reports that some users on Sky Broadband in UK are having trouble loading Wix sites. The issue appears to be with the internet service provider itself, not with Wix.

While we investigate, we recommend contacting Sky's support team directly for assistance. You can also try switching to a different internet connection, such as your mobile phone's data, to access your site.
Posted Sep 15, 2025 - 12:19 UTC
This incident affected: Site Loading (Site Loading).