RESOLVED: We're investigating a potential issue with wixstudio.io sites not loading.
Incident Report for Wix
Resolved
This issue is now resolved. We thank you for your patience and understanding as we worked to resolve this issue.
Posted Nov 09, 2023 - 22:47 UTC
Update
The team is working with the DNS provider to resolve the issue. Until resolved we created a workaround in order for you to view the live site using a temporary free site URL https://account-name.wixsite.com/site-name. To access your free studio live site, please replace wixstudio.io with wixsite.com in the URL.

You can continue to create, edit, and preview sites in the editor. Premium sites are not affected.
Posted Nov 09, 2023 - 21:26 UTC
Identified
We're investigating an issue with free wixstudio.io sites not loading, caused by a DNS error. 

The team is working on a workaround to view live free sites and with the DNS provider to resolve the issue.
Posted Nov 09, 2023 - 20:23 UTC
Investigating
Our engineers are currently investigating an issue affecting wixstudio.io sites. Check back here for updates.
Posted Nov 09, 2023 - 18:43 UTC
This incident affected: Site Loading (Site Loading).