RESOLVED: Major Issue affecting multiple services
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 10:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2022 - 10:29 UTC
Investigating
Some users and site visitors may experience issues with multiple services.
Posted Jan 12, 2022 - 10:22 UTC
This incident affected: Site Editing (Wix Editor, Editor X) and Site Loading (Site Loading).