RESOLVED: Wix Support Site is Down
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 15:06 UTC
Investigating
We are currently investigating an issue with Wix Support being down and are working to resolve this
Posted Aug 06, 2024 - 14:35 UTC
This incident affected: Customer Care (Help Center, Chatbot).