We're investigating a potential issue with Saving and Publishing inside the Editor.

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 19:16 UTC

Monitoring

Currently the issue should be mitigated for the most users, some may expirience issues on rare ocasions.
Posted Feb 18, 2026 - 18:00 UTC

Investigating

Our engineers are currently investigating an issue affecting Saving/Publishing in Editor.
Check back here for updates.
Posted Feb 18, 2026 - 17:16 UTC
This incident affected: Site Editing (Wix Editor, Wix Studio).