RESOLVED: Major Issue with media uploads
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Apr 04, 2021 - 19:24 UTC
Investigating
Some website owners may experience issues when trying to upload media to their site.
Posted Apr 04, 2021 - 19:08 UTC
This incident affected: Media (Upload).