Issues Accessing Live Sites
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted May 31, 2021 - 17:43 UTC
Investigating
We are currently investigating this issue.
Posted May 31, 2021 - 17:14 UTC
This incident affected: Site Loading (Site Loading).