RESOLVED: Issue With Merchants Using Wix Payments Connected to Adyen

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 18:50 UTC

Monitoring

The issue concerns merchants using Wix Payments connected to Adyen due to a live incident on their side. Please refer to Adyen Status Page for additional information: https://status.adyen.com/
Posted Apr 21, 2025 - 18:49 UTC
This incident affected: Payments (Third-Party Payment Providers).