RESOLVED: Intermittent Issues Affecting Live Site Access

Incident Report for Wix

Resolved

The issue has been confirmed to be resolved.
Posted Mar 26, 2026 - 16:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 15:32 UTC

Investigating

Some website visitors may experience reduced performance when accessing their live sites.
Posted Mar 26, 2026 - 15:21 UTC
This incident affected: Site Loading (Site Loading).