Get Started
RESOLVED: We're investigating a potential issue with sites not loading.
Incident Report for Wix
Resolved
This incident has been resolved.
Posted 4 months ago. Oct 28, 2024 - 14:17 UTC
Investigating
Our engineers are currently investigating an issue affecting some users sites that are unable to load. Check back here for updates.
Posted 4 months ago. Oct 28, 2024 - 13:55 UTC
This incident affected: Site Loading (Site Loading).