RESOLVED: Issues with saving the Wix Editor
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Oct 24, 2021 - 06:25 UTC
Investigating
Some website owners may experience reduced performance when trying to save within the Wix Editor, generating error -10902.
Posted Oct 24, 2021 - 02:17 UTC
This incident affected: Site Editing (Wix Editor).