Resolved: We're investigating issues with processing credit card payments
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Sep 14, 2024 - 10:00 UTC