RESOLVED: PayPal Payments Processing Issue

Incident Report for Wix

Postmortem

The Paypal Payments Processing Issue was caused by something on Paypal’s end.

For more information, when it is availble, please check here: https://www.paypal-status.com/history/production

Posted Oct 16, 2025 - 17:01 UTC

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 17:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 16, 2025 - 16:47 UTC

Monitoring

The issue appears resolved. We are monitoring.
Posted Oct 16, 2025 - 16:47 UTC

Update

We've identified issues with PayPal due to a technical issue on PayPal side.
Please contact PayPal directly for additional assistance with the issue.
Posted Oct 16, 2025 - 16:30 UTC

Update

We've identified issues with PayPal due to a technical issue on PayPal side.
Please contact PayPal directly for additional assistance with the issue.
Posted Oct 16, 2025 - 16:16 UTC

Update

We've identified issues with PayPal due to a technical issue on PayPal's side.
Please contact PayPal directly for additional assistance with the issue.
Posted Oct 16, 2025 - 16:00 UTC

Update

We've identified issues with PayPal due to a technical issue on PayPal's side.
Please contact PayPal directly for additional assistance with the issue.
Posted Oct 16, 2025 - 15:45 UTC

Identified

We've identified issues with PayPal due to a technical issue on PayPal side.
Please contact PayPal directly for additional assistance with the issue.
Posted Oct 16, 2025 - 15:32 UTC

Investigating

We are investigating this issue and Paypal has confirmed the issue is on their side
Posted Oct 16, 2025 - 15:29 UTC
This incident affected: Payments (Third-Party Payment Providers).