RESOLVED: Issue affecting multiple services

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 11:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2026 - 11:27 UTC

Investigating

Some website owners may experience issues on multiple services.
Posted Feb 26, 2026 - 10:51 UTC
This incident affected: Site Dashboard (My Sites, Side Menu), Site Editing (Sign-In, Wix Editor, Wix Studio), and Studio Workspace (Studio Workspace).