Get Started
Resolved: Wix Payments experiencing downtime
Incident Report for Wix
Resolved
This incident has been resolved.
Posted 5 months ago. Sep 16, 2024 - 15:08 UTC
Update
We are continuing to investigate this issue.
Posted 5 months ago. Sep 16, 2024 - 15:00 UTC
Investigating
We are currently investigating this issue.
Posted 5 months ago. Sep 16, 2024 - 14:58 UTC
This incident affected: Payments (Wix Payments) and Stores (Storefront).