Resolved: Potential issue with uploading media in editor
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Mar 19, 2023 - 20:21 UTC
Investigating
Our engineers are currently investigating an issue affecting uploading media in the editor. Check back here for updates.
Posted Mar 19, 2023 - 20:04 UTC
This incident affected: Site Editing (Wix Editor).