RESOLVED: We're investigating an issue with Wix Restaurants.
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Mar 27, 2021 - 18:00 UTC
Investigating
Our engineers are currently investigating an issue affecting Wix Restaurants not loading on live sites.

Check back here for updates.
Posted Mar 27, 2021 - 17:33 UTC
This incident affected: Restaurants (Online Orders).