RESOLVED: PayPal Payments Processing Issue

Incident Report for Wix

Resolved

We experience some issues with PayPal Payments Processing for about 10 minutes.
Issue was resolved by PayPal.
Posted May 20, 2025 - 00:30 UTC