RESOLVED: Some users may experience delays when contacting Customer Care

Incident Report for Wix

Resolved

The incident has been resolved.
Posted Nov 20, 2025 - 08:32 UTC

Update

We are continuing to investigate this issue.
Posted Nov 20, 2025 - 08:30 UTC

Investigating

We’re working on a solution, try again later.
Posted Nov 20, 2025 - 03:33 UTC
This incident affected: Customer Care (Help Center).