RESOLVED: Our Customer Care are temporarily unavailable

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 22, 2024 - 16:56 UTC

Investigating

Currently our phone support is unavailable. We’re working on it. Subscribe to the issue to get notified when it’s resolved.
Posted 1 year ago. Apr 22, 2024 - 15:59 UTC
This incident affected: Customer Care (Chatbot).