RESOLVED: We're investigating a potential issue with receiving Wix Stores order confirmation emails
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 20:36 UTC
Identified
The issue affecting Wix Stores order confirmation emails has been resolved for new orders. Our engineers are working on delivering affected confirmation emails.
Posted Dec 14, 2021 - 17:23 UTC
Update
We are continuing to investigate this issue.
Posted Dec 14, 2021 - 17:04 UTC
Investigating
Our engineers are currently investigating an issue affecting receiving Wix Stores order confirmation emails.
Check back here for updates.
Posted Dec 14, 2021 - 14:33 UTC
This incident affected: Stores (Store Management).