Get Started
RESOLVED: Call Center Support Unavailable - Please Use Chat for Support
Incident Report for Wix
Resolved
This incident has been resolved. Thank you for your patience while we worked to resolve this issue.
Posted 5 months ago. Sep 04, 2024 - 18:10 UTC
Update
We are continuing to investigate this issue. Thank you for your patience. Please continue to utilize the Chat option for your support needs.
Posted 5 months ago. Sep 04, 2024 - 17:17 UTC
Update
We are continuing to investigate this issue. Thank you for your patience. Please continue to utilize the Chat and Email options for your support needs.
Posted 5 months ago. Sep 04, 2024 - 16:31 UTC
Investigating
We are currently investigating this issue. For now please use chat or email support.
Posted 5 months ago. Sep 04, 2024 - 15:12 UTC
This incident affected: Customer Care (Help Center).