RESOLVED: Major Issue affecting multiple services
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Jul 14, 2021 - 14:23 UTC
Investigating
Some website owners and site visitors may experience issues with multiple services.
Posted Jul 14, 2021 - 14:19 UTC