RESOLVED: Free Wix Studio Live Sites Not Loading (404 error)
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 11:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2024 - 11:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2024 - 11:06 UTC
Investigating
Our engineers are currently investigating an issue affecting live sites created on Wix Studio. Check back here for updates.
Posted Feb 14, 2024 - 11:03 UTC
This incident affected: Site Loading (Site Loading).