RESOLVED: Potential issue with payments on live sites.
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 13:36 UTC
Investigating
Our engineers are currently investigating an issue affecting payments on live sites. Check back here for updates.
Posted Mar 16, 2023 - 13:22 UTC
This incident affected: Payments (Wix Payments, Third-Party Payment Providers).