Wix system status

Real-time health for Wix products and services

Track current availability, recent incidents, and service updates across the Wix platform.

Report a problem with Wix

Need help right away? Visit support.wix.com. Some issues affecting a small number of users may not appear here immediately.

Issue affecting multiple services

Incident Report for Wix

Resolved

This incidents has been resolved. We thank you for your patience.
Posted Jun 20, 2022 - 14:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2022 - 14:04 UTC

Investigating

Our engineers are investigating issues impacting multiple Wix services.
Come back here for updates.
Posted Jun 20, 2022 - 13:12 UTC
This incident affected: Site Editing (Wix Editor) and Site Loading (Site Loading).