Get Started

RESOLVED: Issue with Checkout Flow for some customers

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 12 days ago. Mar 24, 2025 - 17:08 UTC

Identified

Some website visitors may experience issues when checking out on Wix sites.
Posted 12 days ago. Mar 24, 2025 - 17:05 UTC
This incident affected: Stores (Checkout).