Get Started

RESOLVED: Multiple Issues Affecting Wix Stores

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 03, 2024 - 12:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 1 year ago. Apr 03, 2024 - 12:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted 1 year ago. Apr 03, 2024 - 12:02 UTC

Investigating

Our engineers are currently investigating an issue affecting Wix Stores and Ecommerce related services. Check back here for updates.
Posted 1 year ago. Apr 03, 2024 - 11:40 UTC
This incident affected: Stores (Storefront, Checkout).