Get Started

RESOLVED: We're investigating a potential Issue affecting multiple services

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 10 months ago. Jun 06, 2024 - 08:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Jun 06, 2024 - 08:09 UTC

Update

We are continuing to investigate this issue.
Posted 10 months ago. Jun 06, 2024 - 08:05 UTC

Investigating

Some website owners may experience issues on multiple services.
Posted 10 months ago. Jun 06, 2024 - 08:04 UTC
This incident affected: Site Editing (Wix Editor, Editor X).