RESOLVED: Issues with Loading The Wix App Market

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 27 days ago. Mar 08, 2025 - 18:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 27 days ago. Mar 08, 2025 - 18:14 UTC

Investigating

We are currently investigating this issue.
Posted 27 days ago. Mar 08, 2025 - 17:50 UTC
This incident affected: App Market (Market Place).