Get Started

RESOLVED: Minor Issue affecting multiple services

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 10 months ago. Jun 02, 2024 - 11:02 UTC

Investigating

Some website owners may experience issues on multiple services.
Posted 10 months ago. Jun 02, 2024 - 10:48 UTC