Major Issue affecting sites and multiple services
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 19:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2022 - 19:21 UTC
Identified
We are currently investigating a major issue in one of our data centers and are working to restore service.
Posted Jun 16, 2022 - 19:13 UTC
This incident affected: Site Dashboard (My Sites), Site Loading (Site Loading), and Site Editing (Wix Editor).