Get Started
We're investigating a potential issue with Wix Editor.
Incident Report for Wix
Resolved
This incident has been resolved.
Posted 2 months ago. Dec 17, 2024 - 10:36 UTC
Investigating
Our engineers are currently investigating an issue affecting Wix Editor. Check back here for updates.
Posted 2 months ago. Dec 17, 2024 - 10:27 UTC
This incident affected: Site Editing (Wix Editor).