RESOLVED: Certain Sites Experiencing Server Error

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 14:29 UTC

Monitoring

A fix has been implemented by our engineers and we are monitoring the results.
Posted Aug 18, 2025 - 12:43 UTC

Update

We are continuing to investigate the issue related to a server error displaying on certain live sites.
Posted Aug 18, 2025 - 09:19 UTC

Update

We are continuing to investigate this issue.
Posted Aug 18, 2025 - 08:10 UTC

Investigating

We are seeing "the server encountered a temporary error" when trying to open certain live sites.
Posted Aug 18, 2025 - 07:42 UTC
This incident affected: Site Loading (Site Loading).