RESOLVED: Some Users Unable to Access Live Sites in Brazil

Incident Report for Wix

Resolved

The site loading issue affecting users in Brazil is now resolved. The issue was related to external network conditions with third-party Latin American ISP providers. Sites are now loading normally.

No further action is required. We will continue monitoring to ensure stability.
Posted Aug 15, 2025 - 02:53 UTC

Monitoring

The routing path issue between a user’s ISP and Wix affecting site loading in Brazil appears to have resolved itself. Sites are now loading normally. We will continue monitoring for the next 15 minutes to ensure stability before closing the incident.
Posted Aug 15, 2025 - 02:36 UTC

Update

We’re aware of an issue that appears to manifest on the routing path between a user's ISP and Wix for some users trying to access Wix sites from Brazil

In case you encounter this issue, please contact your ISP directly in order for them to take measures on their side.

We are monitoring their progress and will provide an update once we see the issue is resolved.
Posted Aug 15, 2025 - 01:32 UTC

Update

We’re aware of an issue that appears to manifest on the routing path between a user's ISP and Wix for some users trying to access Wix sites from Brazil

In case you encounter this issue, please contact your ISP directly in order for them to take measures on their side.
We are monitoring their progress and will provide an update once we see the issue is resolved.
Posted Aug 15, 2025 - 00:07 UTC

Identified

We’re aware of an issue that appears to manifest on the routing path between a user's ISP and Wix for some users trying to access Wix sites from Brazil

In case you encounter this issue, please contact your ISP directly in order for them to take measures on their side.

We are monitoring their progress and will provide an update once we see the issue is resolved.
Posted Aug 14, 2025 - 22:44 UTC
This incident affected: Site Loading (Site Loading).