RESOLVED: Major Issue with PayPal Checkout
Incident Report for Wix
Resolved
This incident has been resolved on PayPal's side. Thank you for your patience in this matter.
Posted Mar 14, 2022 - 19:17 UTC
Investigating
Some website visitors may experience issues when trying to checkout with PayPal. PayPal is currently investigating the issue.

Please follow along at https://www.paypal-status.com/product/production
Posted Mar 14, 2022 - 18:56 UTC
This incident affected: Payments (Third-Party Payment Providers).