RESOLVED: We're investigating a potential issue with feedback links, app download links and shortened links
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 13:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 12, 2024 - 02:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2024 - 14:19 UTC
Investigating
We are currently investigating this issue.
Posted Mar 11, 2024 - 11:41 UTC
This incident affected: Mobile Solutions (Spaces by Wix, Fit by Wix, Dine by Wix).