PayPal Service Disruption with Online Checkout
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 17:12 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 21, 2021 - 17:00 UTC
Identified
Some website visitors who try to checkout with PayPal may experience issues when connecting to PayPal. There is currently a service disruption on PayPal's end that they are investigating.

PayPal Status Page - https://www.paypal-status.com/product/production
Posted Apr 21, 2021 - 16:58 UTC
This incident affected: Payments (Third-Party Payment Providers).