RESOLVED: Issue with accessing Live Sites
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted May 31, 2021 - 15:20 UTC
Update
We've identified the problem and working to fix it as soon as possible
Posted May 31, 2021 - 14:58 UTC
Identified
Some website visitors may experience issues when trying to open live sites.
Posted May 31, 2021 - 14:55 UTC
This incident affected: Site Loading (Site Loading).