RESOLVED: Certain Sites Experiencing Server Error

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 17:49 UTC

Monitoring

We applied another fix to mitigate the issue, monitoring the results.
Posted Aug 18, 2025 - 14:43 UTC
This incident affected: Site Loading (Site Loading).